How to install exfat-fuse on 10.5.8 PPC

Just a few notes for the future.

Macports installs a lot of dependencies, plus it cannot compile osxfuse (can’t use another port anymore) because osxfuse wants XCode 3.2, which doesn’t run on Leopard (only Snow Leopard). Use the binary provided on the official OSXFUSE website.

Use tigerbrew to install python 2.7 and scons. Just to install scons, Macports will install a lot of different crap, but at least it knows that python 2.7 is required to get scons to work properly. scons 2.3.4 is supposed to run on python 2.5.1 according to the documentation, but if you try you will end up with this error. Apparently ‘as’ only works with exceptions since python 2.6:
Import failed. Unable to find SCons files in:
/usr/local/bin/../engine
/usr/local/bin/scons-local-2.3.4
/usr/local/bin/scons-local
/usr/local/lib/scons-2.3.4
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/scons-2.3.4
/usr/local/lib/python2.5/site-packages/scons-2.3.4
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scons-2.3.4
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/scons-2.3.4
/usr/local/lib/scons
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/scons
/usr/local/lib/python2.5/site-packages/scons
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scons
/System/Library/Frameworks/Python.framework/Versions/2.5/lib/scons
Traceback (most recent call last):
File "/usr/local/bin/scons", line 190, in
import SCons.Script
File "/usr/local/lib/scons-2.3.4/SCons/Script/__init__.py", line 76, in
import SCons.Environment
File "/usr/local/lib/scons-2.3.4/SCons/Environment.py", line 56, in
import SCons.SConf
File "/usr/local/lib/scons-2.3.4/SCons/SConf.py", line 199
except TypeError as e:
^

After you have python 2.7 and scons, you can follow the instructions on the exfat-fuse website. And it works.

Leave a Reply

Your email address will not be published. Required fields are marked *